The team has thoroughly tested the fix and all systems appear to be fully stable and operational. We will continue monitoring overnight and provide a final update in the morning.
Posted Mar 05, 2026 - 18:04 UTC
Monitoring
The fix has deployed and is live. Calls should now display on the conversation list as per usual Testing is underway to confirm the fix.
Posted Mar 05, 2026 - 13:12 UTC
Update
The fix for this issue will be deployed in two parts. Part one is currently being deployed, after which final work and testing of part two will resume.
Posted Mar 05, 2026 - 12:07 UTC
Identified
Some customers are currently experiencing an issue where the conversation page won't load or is extremely slow in loading. We have identified the cause and are currently working on a fix. We will provide another update when the fix is deployed and share a detailed overview of the issue via email.
Posted Mar 05, 2026 - 11:41 UTC
This incident affects: Core Services (General Performance & Availability).