Monitoring
A fix for the Agent Filter issue has been deployed and confirmed working, previously affected organisations can now filter by agent name as expected.
We'll continue monitoring the fix for the next hour.
Investigating
We're aware that the Agent Filter is currently displaying a "Too many results. Please refine your search" message. Our engineers are investigating, and we'll share updates as soon as we have them.