Investigating
The engineering team was able to fix the underlying issue. Conversations will now start processing.
Investigating
We are currently experiencing an issue where calls uploaded since last night have not been processed and are not appearing on the platform.
Our engineering team has identified the issue and is working urgently on a fix. We will provide a further update as soon as we have more information.