Resolved
This issue has been fully resolved.
Investigating
Some customers may experience slower load times on the Channels and Conversations list page. We expect this to be resolved shortly and will update this page once normal performance is restored.