Write-up published
Resolved
A fix has been deployed and the Agent Insights dashboard is working as expected. Agent drill-down views and data should now load correctly.
Investigating
We are currently investigating an issue affecting the Agent Insights dashboard. Customers may see missing data or errors when viewing individual agent details.