Problem: A high number of calls failed to transfer from RingCentral to Voyc, with server errors reported by the integration.
Impact: Most calls failed to transfer to Voyc yesterday due to server errors.
Causes: We hit RingCentral's rate limit, which caused calls to fail when transferring to Voyc.
Steps to resolve: All affected calls have been re-queued and are expected to be processed within a few hours. We are reviewing rate limit headers to improve retry and back-off logic.
Identified
Problem: A high number of calls failed to transfer from RingCentral to Voyc, with server errors reported by the integration.
Impact: Most calls failed to transfer to Voyc yesterday due to server errors.
Causes: We hit RingCentral's rate limit, which caused calls to fail when transferring to Voyc.
Steps to resolve: All affected calls have been re-queued and are expected to be processed within a few hours. We are reviewing rate limit headers to improve retry and back-off logic.
Investigating
We're experience a high number of errors when transferring calls from RingCentral to Voyc.
This is being resolved as a matter of urgency