Monitoring
The fix has been deployed and tests have been conducted. The report confidence filter now works and the team will be monitoring this fix.
Identified
Our lead engineer has identified the issue and a fix will be implemented in the next hour.