No components marked as affected
Resolved
This issue was confirmed as resolved 24 February
Investigating
Users appear to still receive email notifications after they have left or have been removed from the workspace. An example of this is alerts notifications if they had been subscribed to alerts.
Our engineering team is currently investigating this.