Resolved
Functionality is back to normal.
Monitoring
Our team has deployed a fix that should resolve this issue. We are monitoring for the next week to confirm it is now resolved
Identified
There are some records missing from the part of the system that syncs conversation data to the conversation list, which can contribute to conversations not appearing when filtering.
Our senior engineering team has a project to reduce the complexity of our data processing systems behind the scenes. They aim to have this project completed by the end of March, which will ultimately resolve this issue.